Jump to content
This site uses cookies! Learn More

This site uses cookies!

armedunity.com uses cookies to improve user experience.

By continuing to use this site, you agree to allow us to store cookies on your computer.

  • 0
Sign in to follow this  
fpsarmedunity

fps kit 1.6 unequip animation not play

Question

Hi i'm trying to add osme custon wpeaon to my fps kit template but  i noticed a weird thing that happen even with stock  weapons..

 

basically even if i set a correct animation on the "Switch" field on the WeaponScriptNew.cs inside the inspector  the animation is not played when weapon is unequipped and weapon simply disapper form scene and equip animation for the new selected weapon is correcly played......and i noticed that this happen even for stock weapons but  i didtnt notice this before...

 

is this the behaviour kit has to work for  or i missed something?

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts


  • 0

nope i think it's a design choise and fpskit doesnt play unequip anim but switch instantly..afaik

 

btw is there a ways we can add this functionality??

 

 itried to add a coroutine and adding hide anims in to WeaponsScritpNew.cs but doesnt work

 

with tihs  errro message on test game after i pickup and deseslect wepaon(fireaxe)

 

Coroutine couldn't be started because the the game object 'FireAxe' is inactive!
 

 

Please login or register to see this code.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...